Installing SharePoint 2013 Preview on Windows Server 2008 r2

July 17th, 2012 | Posted by Jeffrey Paarhuis in Uncategorized

I found an article on the internet that could tell me how I can install SharePoint 2013 on a Windows Server 2012 machine. I however, just want to install the new SharePoint 2013 Preview on an a familiar machine, without all the Windows Server 2012 Preview nonsense.

I cloned an existing SharePoint 2010 virtual machine, with AD and SQL Server 2008 r2 already configured, uninstalled SharePoint Server 2010 and SharePoint Designer 2010 and started from there. This will also work on a newly configured machine, keeping in mind that we are using AD and SQL Server 2008 r2.

On the first attempt to install SharePoint 2013 (download link), the  autorun wasn’t working, so I opened the folder and ran setup.exe. Then I got a message telling me I need a few components:

  • This product requires Microsoft Identity Extensions.
  • This product requires  Windows Server Appfabric. Install Windows Server Appfabric and re-run setup.
  • This product requires Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB2671763)
  • This product requires Microsoft SQL Server 2008 R2 SP1 Native Client.
  • This product requires the Microsoft WCF Data Services 5.0.
  • This product requires Microsoft Information Protection and Control Client (MSIPC)

So, obviously I forgot to launch the pre-requisites installer first, prerequisiteinstaller.exe.

Now I could install SharePoint 2013 successfully and launch the Configuration Wizard afterwards. But upon configuring the database my system tells me that my SQL server has an unsupported version. I need to apply SP1 of SQL Server 2008 r2: http://www.microsoft.com/en-us/download/details.aspx?id=26727

After completing the configuration wizard, it dropped me into the Central Administration. I tried to run the wizard that generates a complete environment, but it failed and resulted in a corrupt web application. So my advice is, just like SharePoint 2010: skip the wizard and do it manually. I created a new web application and site collection and it works like a charm.

You can follow any responses to this entry through the RSS 2.0 You can leave a response, or trackback.

3 Responses



Leave a Reply to Jeffrey Paarhuis Cancel reply

%d bloggers like this: